Email delivery issues
Resolved
Mar 13, 2026 at 03:02pm UTC
The issue affecting email delivery for some customers has now been resolved.
The disruption was caused by problems with our email provider. Email delivery has returned to normal, and our systems are operating as expected.
We apologize for any inconvenience this may have caused and appreciate your patience while we worked with the provider to resolve the issue.
Affected services
Created
Mar 13, 2026 at 01:06pm UTC
We are currently experiencing issues with email delivery for some customers due to problems with our email provider.
Our team is actively monitoring the situation and working with the provider to resolve it as quickly as possible. We will share further updates as soon as more information becomes available.
Thank you for your patience.
Affected services