Back to overview
Degraded
Service performance degraded
Nov 18 at 01:12pm CET
Affected services
moxso.com
hub.moxso.com
admin.moxso.com
api.moxso.com
moxso-plugin.com
Resolved
Nov 18 at 01:32pm CET
The issue has been resolved, and performance has returned to normal.
Affected services
Created
Nov 18 at 01:12pm CET
Service performance degraded due to an incident with our external provider.
Affected services