Back to overview
Degraded

Emails not being deleted in Outlook

Apr 06 at 09:22pm CEST
Affected services
moxso-plugin.com

Resolved
Apr 10 at 01:50pm CEST

This issue has been resolved.

Created
Apr 06 at 09:22pm CEST

We're currently experiencing an issue where the Outlook plugin is not deleting emails as expected for some clients. Our team is investigating and working on a fix.